data-labeler / flake.nix
osbm's picture
add flake
2b5a8e7
raw
history blame
885 Bytes
{
description = "data labeler environment";
nixConfig = {
extra-substituters = [
"https://nix-community.cachix.org"
];
extra-trusted-public-keys = [
"nix-community.cachix.org-1:mB9FSh9qf2dCimDSUo8Zy7bkq5CX+/rkCWyvRCYg3Fs="
];
};
inputs.nixpkgs.url = "github:nixos/nixpkgs/nixpkgs-unstable";
outputs = {nixpkgs, ...}: let
system = "x86_64-linux";
pkgs = import nixpkgs {
inherit system;
config.allowUnfree = true;
config.cudaSupport = true;
};
in {
devShells."${system}".default = pkgs.mkShell {
packages = with pkgs; [
(python312.withPackages (
ppkgs:
with python312Packages; [
pip
numpy
pandas
streamlit
]
))
zip
unzip
git
wget
curl
];
};
};
}